Lab 5. Making Maps

The goal: To learn about the GIS technique and cartographic standards for the map making process.

Objective: Using ARCVIEW software learn how to make maps.

Software for the lab: ARCVIEW.


1. LAYOUT

1. What is a layout?

- It is a combination of Project components; Views, Charts and Tables, along with other graphical elements such as scale bars, legends, text and north arrows into a single output document used primarily for hard copy output.

  (Hutchinson and Daniel, 1995)

- It gives you control over the format, orientation, resolution and size of your hard copy output.

- The Frame is the elemental building block of the Layout. It contains the components of the Project or the graphical elements. Project components can be combined into one Layout (combining a View with a Chart, for example).

- The Layout is/can be dynamically linked to the other components, so any changes made in the Views, Charts and/or Tables will be reflected simultaneously in the corresponding Layout. This link can be deactivated in order to create a static Layout representing a ‘snapshot’ of the View in its current state.

- Layout templates can be created to bring uniformity to your output productions.

Two ways to begin your Layout:

1. Open a New Layout from your Project management window and populate it with Frames and Graphics.

   - or -

2. If you are working with Views, select an option “Layout...” from the View menu. This will prompt you for the orientation of your Layout. The default choices are Landscape and Portrait. You may also create your own Layout template which allows you to save a particular Layout style and use it repeatedly. If you use the Portrait or Landscape option, a layout will appear which will include a default scale bar, north arrow, legend and layout title.
NOTE:
Make sure that your Map and Distance Units are set in the View Properties or the scale bar will appear as an empty gray box with “Unknown Units” remark.

Start Arcview and open new View. Add to this view theme “subbas24eoh” from the “/usr/manhattan/gis_class/yxg/data”. Set up properly your View’s properties. Call your view “Sub-basin Map”

Using the Layout component of ArcView to generate a map.

1. The building blocks of the Layout are Frames and graphics. Frames allow you to insert the contents of other ArcView components (View, Charts and Tables) into the Layout. The Draw Tool allows you to add graphical elements (lines, boxes, points) anywhere in the Layout.
2. The ArcView Project components may be added to the Layout at any time, but it is usually best to set up your Views, Tables and Charts just as you would like them to appear in the final output, then add them to the Layout as frames.

Page Setup for Output

Open a new layout, ‘layout1’, and define the graphics page (i.e. the format of the output). This is done through Layout ---> Page Setup dialog window (see below). In this window the page size, page units, orientation (landscape or portrait), margin definition and output resolution are defined. Page units are those used for operations on the layout page (ex. grid spacing). The output resolution is dependent upon the resolution of the output device. Use the options as they are set in the dialog window below.
Adding Components to the Layout.

A. Adding a View

Select the above icon, bring the cursor into the layout window and holding down the left mouse key, drag a box where you would like the view frame to appear.

The following dialog box will appear, use the options as they are set below.

1. **Live Link** - If the box is checked then any changes made in that View will be reflected in the Frame. If this is not checked off, then a ‘snapshot’ of the View will be created and any change made to the View after this will not affect this View Frame in your layout.

   NOTE: On UNIX version of Arcview broken live link made layout independent only from “zoom” and “pan” functions. Editing changes done to the “unlinked” view can be still reflected in “unlinked” layout.

2. **Scale** - set the scale of the contents of the view frame.
   a. **Automatic** - The scale is determined by the width of the view frame. If the frame is resized then the scale is adjusted so the view ‘fits’ within the resized frame.
   b. **Preserve View Scale** allows you to add a View to the Layout and preserve the scale of the View in the Frame, so some of the View may not appear in the Layout Frame. If this box is not checked then what appears in the View window will be mirrored in the Frame regardless of it’s size. The MAP UNITS must be set in the View Properties for this option to work.
c. **User Specified Scale** - The scale of the view frame can be set regardless of the scale of the view. Enter the scale in the scale field of the View Frame Properties dialog window. Changing the scale of the View will not change the scale set for the View Frame. The MAP UNITS must be set in the View Properties for this option to work.

3. **Extent** - Sets how the data will appear in the View Frame.
   
a. **Fill View Frame** - Arcview will attempt to fill the view frame with as much data from the View as possible.
   
b. **Clip to View** - This will display, in the view frame, only those features currently visible in the view. Remember, if your live link is ‘on’, then any changes made to the View will be reflected in the corresponding View Frame.

4. **Display** - when the layout will refresh itself
   
a. **When Active** - the View Frame in the Layout will be redrawn only when the Layout component of the Project is active. This is a time saver when you have a live-link view with large data sets because the Layout does not need to redraw every time there is a change to the View.
   
b. **Always** - will refresh the View Frame in the Layout anytime there is a change to the View with which it is associated. When Active will redraw the layout faster than Always.

5. **Quality** - how the frames of the Layout will appear.
   
   **Presentation** - the elements of the View Frame will display the elements of it’s View.
   
   **Draft** - the Frame will appear as a shaded box and hold the place of the View. This can be toggled back to Presentation at any time. This is another redisplay time saver if you are working with themes with large numbers of features.

**NOTE:**

The Display and Presentation options are used primarily to speed the display process by not having the View Frame redraw every time the View is manipulated. The Display When Active and Draft Presentation options will decrease or increase the speed of redisplay, respectively. Turning the Themes “off” in the View until you are satisfied with the Layout and ready to print will also increase the speed of redplays.

Add the View called “Sub-basin Map”. make sure it occupies about 3/4 of your page.
EEE 1001 Introduction to GIS technology for visualization and analysis of environmental data.

B. Adding a Legend

1. By selecting this tool you can drag a box in the Layout which will be occupied by the legend (i.e. Table of Contents) from your View “Sub-basin Map”.

2. Once the rectangle is drawn, you are prompted to select the View Frame from which to create the legend. Whether you would like the Legend Frame to display only when the Layout is active or Always (even when the Layout is not active) and will the frame be Presentation or Draft (Same as in the View Frame). Select View “Sub-basin Map”.

3. If the Legend Frame’s associated View Frame is Live Linked to it’s View, then any changes made in the View Table of Contents will be reflected in the Legend Frame, if the View Frame is Live Linked Static then the associated Legend Frame will also remain Static.

4. Any text size and font changes made to the Legend Frame can be done in Layouts: Window ---> Show Symbol Window, but changes to the Legend symbols and definition should be made in the associated View using Theme Properties and the Legend Editor.

NOTE: To select Frames and graphical elements for editing, use the Select Tool.

C. Adding a Scale Bar

1. The Scale Bar Frame is associated with a View Frame in the Layout. This is a live link so when the View is changed, the Scale Bar will change along with it.

2. Map units must be set in the View Properties dialog box or your Scale Bar Frame will appear as an empty box. Map units can be set after the Scale Bar Frame is created.

3. You are prompted for;
   a. the View Frame to associate the Scale Bar to,
   b. the style of the scale bar (a ratio or any of the bar types),
   c. the units in which the scale will be displayed,
   d. the distance interval between each graduation on the scale, and
   e. the number of those intervals both to the left and right of the zero.
4. **Preserve Interval**

   If checked and the View Frame is resized, then the scale bar will resize as well maintaining the specified interval. If not checked and the View frame is resized, then the scale bar will maintain the same shape but the specified interval will be altered.

5. A blank Scale Bar Frame can be created to be used as part of a Layout template and filled in later with associated View Frames.

**D. Adding a North Arrow**

   Simply create a North Arrow Frame, choose the style and angle of rotation in degrees if necessary.

**E. Adding a Chart**

1. When adding a Chart Frame to your Layout, the Chart being added *must be open* or the Frame will appear as a blank box.

2. Again you can specify in the Chart Frame dialog box if you want the chart to redisplay only when the Layout is Active or Always and whether you want it set as Draft or Presentation. When Draft is set, the Chart will appear as a blank box, this can be changed to presentation at any time by double clicking the Chart Frame in the Layout with the Select button and the Chart Frame dialog box will appear.

**F. Adding a Table**

1. When adding a Table Frame to the Layout the Table being added *must be open* in your Project or the Frame will appear as a blank box.

2. Again you can specify in the Table Frame dialog box if you want the table to redisplay only when the Layout is active or always and whether you want it set as Draft or Presentation. When Draft is set the table will appear as a blank box, this can be changed to presentation at any time by double clicking the Table Frame in the Layout with the Select button.

3. The Table Frame can be a maximum of 80 characters in width, so make sure that the visible fields in the table do not exceed this number. The frame will accommodate the left most columns of the table.
NOTE:
The Table and Chart Frames are always ‘live linked’ to their associated tables and charts, so any changes made to the Tables or Charts are reflected in their Frames.

G. Adding Graphics using the Picture Frame.

1. When adding a Picture Frame to the Layout you are prompted for the file name of the graphic. Type the name in including the path if it is stored in a different directory or Browse through a file manager pop-up window for the graphic. The imported graphics cannot be edited in ArcView but the Picture Frame can be moved and resized. The following file types are supported by ArcView.

   Band Interleaved by Line (*.bil)
   Band Interleaved by Pixel (*.bip)
   Band Sequential (*.bsq)
   CompuServe GIF (*.gif)
   ERDAS GIS (*.gis)
   ERDAS LAN (*.lan)
   IMPELL Bitmap (*.rlc)
   MacPaint (*.mcp)
   Nexpert Object Image (*.nbi)
   Sun Raster (*.rs)
   TIFF Bitmap (*.tif)
   Windows Bitmap (*.bmp)

2. These graphics can be photos, scanned documents and spreadsheets from other software.

H. Zoom Buttons.

1. Zoom to the Page

   This button allows you to enlarge the layout currently active to fit the size to the Layout window.

2. Zoom to Display the Actual Size of the Layout

   This button will zoom to the portion of the page size that will fit in the Layout window. For example, if your page size was set at 22”x34” then only a small portion of that page will be redisplayed in the Layout window. The scale of the View Frame will match that of the scale of the View which is related to.
I. Available Graphics Tools (same as with the View component)

NOTE:
All of the following can be modified by first selecting the graphic, then opening the Symbol Palette under the Window menu (i.e. color, size, fill pattern, etc.).

1. Place a point on the Layout.

2. Place a straight line on the Layout.

3. Place a multi segmented line on the Layout.

4. Create a rectangle on the Layout.

5. Create a circle on the Layout.

6. Create a polygon on the Layout.

7. Create text on the Layout.

J. Positioning Graphical Elements - there are several ways to place the graphical elements of the Layout throughout the display window.

1. Grid Spacing in Layout menu ---> Properties menu allows you to created a grid on the layout which can be used to align or ‘snap’ Layout elements in vertical or horizontal alignment. The spacing can be adjusted and the grid can be hidden from view but still be active (Layout ---> Hide Grid). It will not print out on hard copy, whether it is visible or not.

2. You can select several features and group them so they will all move together as if they
were one graphical element. They can then be ungrouped. Use the **Select tool** along with the Shift key to select multiple Layout elements by clicking on them or dragging a box completely around them.

**Grouped:**

![Grouped](image)

**Ungrouped:**

![Ungrouped](image)

**NOTE:**

GRAPHIC menu ---> SIMPLIFY will ungroup any selected frame (View, Chart, Scale, etc.). For example, if you selected a Legend Frame it would be treated as one element, but if it were simplified then every element of the Legend would separated and treated as a unique element. This allows for the editing of elements of a Frame without editing the whole Frame. All of the elements of the Frame can be regrouped again by selecting all of the elements of that frame and clicking the Grouped button. This can be useful to edit Legends.

3. Align selected elements under the Graphics menu allows you to align SELECTED graphical elements vertically or horizontally (see dialog box below).

- **Vertical Alignment**
  a. Same Height - each selected graphic will have the same height, the default is the average height of selected graphics.
  b. Equal Distance - leaves the same vertical space between selected graphical elements.
  c. Guide - the y coordinate to which the selected elements are aligned to.

- **Horizontal Alignment**
  a. Same Width - each selected graphic will have the same width, the default is the average width of the selected graphics.
  b. Equal Spacing - leaves the same horizontal space between selected graphical elements.
  c. Guide - the x coordinate to which the selected elements are aligned to.
4. Size and position graphical elements works with only ONE selected element and it allows you to position an element relative to the edges of the page and modify its height and width. This can be performed on any of the Frame types. The scale of any of the View Frames can be modified in this window.

- Preserve Aspect Ratio (if checked) will preserve the ratio between the width and the height dimensions. So any change made to the width field will cause a change in the height field and visa versa.

5. Bring to the Front and Send to the Back Buttons are useful when separate Frames and graphical elements overlap or cover each other. For example if you add a neat line around the perimeter of the Layout after all other Frames are added, you will not be able to select elements of the Layout even though they can be seen. This is because the neat line box is “covering” all of the other elements. If you select the neat line box and either click the Send to Back button or select Send to Back from the Graphics menu. This will place the neat line box “behind” all of the other Layout elements.

K. Store Layout as a Template - if you need to create multiple Layouts and they have to have the same appearance, you can save a Layout as a Template and use this page design in the creation of new Layouts.
1. Begin by creating a blank Layout (landscape or portrait) and edit the Layout ---> Page Setup dialog box.

2. Add the various frames (View, Chart, Table) which you will need to the Layout and when you are prompted in the dialog box for the View/Chart/Table to associate the frame to, choose ‘Empty View/Chart/Table’.
   *Remember: tables and charts must be open for them to be visible in the layout with which they are associated. This will only be necessary when you are ready to populate your template with a View.

3. Add your Legend/North Arrow/Scale bar Frames and again associate them with the ‘Empty View’.

4. Add a neatline.
   * Don’t forget to ‘Send it to the Back’ (see icon above) so you can select the other elements and frames in the Layout.

5. Add a title.

6. Position your Layout elements where you want them and choose Layout ---> Store As Template and you will be prompted to name the template (use one which you will recognize later) and select an icon which will represent the template (see below). Click the Select button to see a list of icons to choose from.

![Template Properties](image)

- **Name:** Template
- **Icon:** [Select]
- **OK**
- **Cancel**
3.2 Layout Exercise

- Include the following in your View:

```
/usr/manhattan/gis_class/yxg/data/basin24eoh   reservoir basins
/usr/manhattan/gis_class/yxg/data/stream24eoh  streams
/usr/manhattan/gis_class/yxg/data/water24eoh   waterbodies
/usr/manhattan/gis_class/yxg/data/sites24eoh   hydrological sampling sites
/usr/manhattan/gis_class/yxg/data/eoh24road    roads
```

and call your View1: Kensico Basin View. Make sure that View properties area set correctly.

1. Display reservoir basins and define Theme Properties so that the only Kensico Basin outline appears in the View. Use “Definition” Icon in Theme Properties Menu, followed by the Theme Properties Query Builder (click on the ‘hammer’ icon). Change the Theme name to Kensico Basin. Use Symbol Window to get Palette and select color for the basin boundary outline.

2. Do the same as above for the streams and waterbodies (make them a dark shade so they stand out against the light background). Change the Theme names to Streams and Waterbodies, respectively. They should be the same color since they are both water features.

3. Activate the sites24eoh theme and under Theme menu ---> Properties
   a. Use ‘ag-sitename’ as the Label Field. Check-off the box “Scale Labels”
   b. Change the Theme name to Hydrological Sampling Sites.
   c. Select out the sample sites from just the Kensico Basin using “Definition” icon and Theme Query Builder.
   d. Click ‘OK’

4. Use Theme ---> AutoLabel for just the Hydrological Sampling Sites theme. Open the Symbol Palette (Window menu) and change the font size of the labels to 10 and the font to Palacio. Change the point symbol and size if you wish and position the site names so they do not overlap one another or other sites but are adjacent to their respective site. Use “Zoom In” and “Zoom Out” buttons to manage label manipulation. Remember that in the theme definition menu the box “Scale Labels” was checked-off. Therefore during “Zooming” labels do not change their size.

5. Add the roads for just Kensico Basin (Use Theme Properties Query Builder!) , change the Theme name to Roads and make the line symbol different than that of the streams so they can be differentiated from other themes on your hardcopy output.

Order the Themes in the Table of Contents from top to bottom:
Hydrological Sampling Sites;
Roads;
Streams;
Waterbodies;
Kensico Basin.
Activate the Kensico Basin Theme and Zoom to Active Theme button.

7. Create a portrait format Layout by either choosing View menu --> Layout .... - or - go to Layout --> New layout and add the Kensico Basin View, legend, scale bar and title. Don’t forget your neat line (use the rectangle graphic tool).

8. Move elements around, change font styles and sizes, resize the View Frames, add a Title using the Text tool. Place the Columbia University logo in the upper left corner using the image file from the directory /usr/manhattan/yxg/data/logo.gif

9. To print the Layout, File menu > Print and replace lp on the printer line with your printer’s name.

10. Save this project as “Maps.apr” in your directory. Send me e-mail.

HOMEWORK.

Make a map with the following elements:

1. Basin boundaries (basin24eoh)
2. Reservoirs (res24eoh)
3. Labels for all reservoirs
4. Labels for all basins
5. Table with the “basin area vs. reservoir area” ratio.
6. Legend with the symbols for basin boundaries and reservoirs.
7. Two scale bars: one with kilometers and another one with miles. Place the scale bar with miles under the scale bar with kilometers.
9. Columbia University logo
10. Map Title “Basins and Reservoirs of the New York City Water Supply, East of Hudson”
11. North arrow.

Export this map into a postscript file and save it in your directory. Give it your login name with extension “.eps”. Send me e-mail with location of the postscript file. I will print your maps and bring them to the next class for discussion.

Use any colors and design you want, but be within cartographic standards.