Quick Introduction to Macromedia Director

Windows: Review functions and relationships between the main windows of Director:

**Stage:** Playback display area, draggable in Director 7 and later; Modify->Movie Properties will change Stage size, Background color (and mask color), Default Palette

**Cast:** Assets and scripts reside here; Different Cast member types shown by different icons; How to re-order/re-organize; Naming Cast members

**Score:** Timeline and organizing system for members on Stage; Creating, adjusting, organizing, joining, splitting Sprites in Score; colorizing Sprites to aid organization

**Paint:** Used for simple graphic editing and prototyping; Bit depth; Paint tools; Palette; foreground/background colors

**Message:** Allows you to communicate directly with Director; examine variables; try Lingo statements; Lingo pull-down directories (alphabetic and by category); Examples: “put the date”, “put the time”, “put the platform”, “put the colordepth”

**Control Panel:** controls playback of movie; Frame location display; Frame rate (desired and actual); Frame-by-Frame advance/reverse; Loop vs. halt at end

The **Sprite** concept:
- a Sprite is a single instance of a Cast member (graphic, text, video) when placed on Stage in a certain Frame or series of Frames.
- a single Cast member can be used to create multiple Sprites – changes to one Sprite don’t affect others, but changes to the Cast member will affect all Sprites.
- setting Sprite preferences (File->Preferences)

Review basic animation tools, such as:
- Cast to Time
- Space to Time
- Tweening
- Tweaking and Nudging
- Registration points in the Paint window (bitmap graphics only)

Useful built-in effects:
- Ink Effects – especially Copy, Background Transparent, Matte (see: “Ink Effects tour.dir”)
- Transitions – especially Wipes and Dissolves (see: “Transition tour.dir”)

Lingo basics:
- Lingo pull-down menus in Message or Script Windows (command-Zero) - alphabetical or by category.

Behaviors:
- Intro to the Behavior Library.
TERMINOLOGY:

Channels: The horizontal rows in the Score. These define the layering of elements on the Stage. Items in lower-numbered channels (rows closer to the top of the Score) are displayed first, with items in higher-numbered channels (rows closer to the bottom of the Score) displayed after, and possibly on top of them. “Sprite x” refers to a Cast member that has been placed in the Score in Channel “x”. The layering sequence is upside-down from that in Photoshop, Illustrator, and Flash.

Frames: The vertical columns in the Score. These define the time-based sequence of events during playback. As time passes, playback progresses horizontally from Frame to Frame (left to right). The time it takes to traverse a certain number of Frames depends on many factors. For pure animation in the Score, it is mostly a question of the playback speed (frames-per-second, or fps) assigned to the movie (or that section of the movie), the number and complexity of items in each Frame, and the speed of the computer playing the movie.

Sprite: When an element (Cast member, etc.) appears in the Score Window, in a certain Frame or series of Frames, it is called a Sprite. The placement of Sprites in the Score, and their location on the Stage, is the visible manifestation of the Director movie on playback.

Cast Members: The individual media elements (graphics, text, video, audio, etc.) and Scripts or Behaviors that are used to create the Director movie and control it through Score settings and with the Lingo scripting language. Cast members are placed in the Score and become Sprites.

Cell: A rectangular area where a Channel and a Frame intersect.

Playback head: When the “playback head” (analogy from audio or video tape players) is on a Frame, that Frame is displayed on the Stage. In D7 and later, the playback head is indicated by a red box on the numbered bar near the top of the Score. For readability, a red line running top to bottom helps visually locate the playback head. In D6 and earlier, a black box in the Frame bar is the indicator. If the playback head is not moving, then the movie is stopped, or else Lingo or a Tempo channel setting is keeping the playback head on the current Frame.

Script: A Cast member containing Lingo commands organized into handlers, or functions, which control the operation of the movie. A single Script may contain just one handler, or many. Sometimes Scripts are defined directly for Cast members such as graphic elements, tying them to those members whenever they are used. There are four basic Script types: Frame Scripts (appear only in the Script channel of the Score), Movie Scripts (globally available to all handlers in the movie), Sprite Scripts or Behaviors (applied to Sprites in the Score), Cast Scripts (defined directly as part of Cast members).

Behavior: A set of Lingo commands that controls the action of a Sprite. Director comes with some pre-made behaviors that you can use as-is, or edit to fit your needs. These may be found in the Library Palette under D7 and later, or Xtras → Behavior Library under D6.
Basic Animation Tools of Director

Placing Sprites on Stage and making a keyframe:
1. Drag a Cast member onto the Stage, starting in a specific Frame.
2. Move it in the Stage to its desired first keyframe location.
3. Click on the Sprite in another Frame where you want a keyframe.
5. Drag the Sprite to its desired location on the Stage for this keyframe.
6. Make more keyframes and continue moving them to the desired locations.
7. You should see an animation path appear on the Stage to help you control and visualize the movement of the Sprite.

Shortcut: hold the Option key, click on the Sprite in a Frame, and drag it. A keyframe is made instantly at that Frame.

Understanding how Sprites are shown in the Score:
1. The round “dots” that appear in a Sprite in the Score are keyframes.
2. Every Sprite has a dot at its beginning, and either a rectangle or dot at their end. A rectangle means that the Sprite has no keyframe at its end - its location and rendition will be same as for the prior keyframe (which could be the start of the Sprite).

Scene Transitions
A transition creates a visible change between two visually different Frames. If two Frames are identical, you will not see a transition, even though one is occurring and actually taking computer time.

To set a transition:
1. Be sure the “Hide/Show Effects channels” button on the upper right side of the Score has been clicked to expose the Transition channel.
2. Double-click the Transition channel (3rd from the top), in the Frame before which you want the transition to occur.
3. Choose a transition you want – for example, “Wipe Right.”
4. Set the speed, duration, and smoothness of the transition. The effect of these settings is highly dependent on the specific transition, the amount of change from Frame to Frame, and the speed of the computer.
5. Select OK.
6. Rewind and play your animation.
7. Transitions can also be done using Lingo – we’ll discuss that later.

Tool Palette – create a text member:
1. Select Window→Tool Palette (command-7)
2. Click on the “A” tool.
3. Click and drag out a text area on the Stage.
4. Select a font and point size, then type your text.
5. To change the font, size, etc., first re-select the text, and then adjust from the Modify→Font menu item (command-T).
6. With the text selected, you can change its foreground and background colors by clicking on the color chips in the Tool Palette window.
7. Note that this type of text member is also called “Rich Text” (RTF) - Director renders the text, with possible anti-aliasing. In D7 and later, a text member can be editable by the user at run-time (not true for D6). There is also a field member, which uses “live” (not rendered) text. Used for different purposes, and the appropriate font(s) must be available on the user's computer at runtime.
Understanding the Animation Path on the Stage:
1. When you see a path on the Stage, there are several larger dots. Each dot represents a keyframe. Some dots are colored to show you the keyframe you are currently on, as well as the first and last keyframe of the Sprite.
2. There are also many smaller dots - these indicate the position of the Sprite in Frames which are NOT keyframes.
3. The more closely packed the dots, the slower the Sprite's movement; the more sparse the dots, the faster the Sprite's movement.

Tweening:
1. Tweening ("in-between-ing") allows you to adjust the automatic interpolation of the Sprite's location and other properties between keyframes.
2. When you have a series of keyframes, highlight the "sprite length" length.
3. Choose Modify→Sprite→Tweening.
4. Set the value for size, location, blend, etc.
5. Set the curvature from linear to normal to extreme.
6. Set the speed for Sharp or Smooth changes.
7. Set the speed for Ease In and Ease Out.
8. Try different settings for each of these to see the effect on the tweening.

Layers:
How to move Sprites behind or in front of other Sprites. Analogous to layers in Photoshop or Illustrator. Remember that in Director, the topmost items appear in higher-numbered channels, farther down in the Score.
1. Use Modify→Arrange commands to move Sprites in front of or behind others.
2. The more forward you bring a Sprite, the more it moves down in the Score channels, and the closer to the “front” level of viewing on the Stage.

Setting a Sprite in a keyframe with just one Frame:
Hold down the Option key, then click-and-drag your Cast member to the Score. Your Sprite should occupy only one cell (Frame) of the Score. (You can also edit File→Preferences→Sprite to set the default Sprite span to 1 Frame.)

Space to Time:
1. Hold down the Option key, then click-and-drag your Cast member to the Score in Frame 1, Channel 1.
2. In the desired time sequence, drag subsequent Cast members to Frame 1, Channel 2, then Channel 3, etc. - all in Frame 1.
3. Highlight all the Sprites in Frame 1.
4. Select Modify→Space to Time.
5. The Sprites should move from being vertically stacked in Frame 1 to being horizontally arrayed in Channel 1 across multiple Frames, creating motion over time.

This technique is good for being able to arrange Sprites relative to each other while working in the single Frame, then distributing them in sequence in the Score.

Auto Distort:
Generate a sequence of images through a distortion or rotate operation in the Paint window.
1. In the Paint window, create a shape (or open a bitmap image in the Paint window).
2. Using the rectangular marquee tool, select the entire Cast member in the Paint window.
3. Select one of the rotation or distortion tools at the top of the Paint window & rotate or distort your image.
4. IMMEDIATELY (without clicking anywhere else), select Xtras→Auto Distort.
5. When the dialog window appears, select the number of images you want Director to auto-generate for the sequence between the starting and final images.
6. Choose Begin. You should see the sequence of images being created in the Cast window.
Changing a movie's background color:
1. Choose Modify → Movie → Properties – the Properties window appears.
2. Click-and-hold the color chip next to the label “Stage Color” to show the palette, or type an HTML hex RGB triplet into the field next to the color chip. The palette used is the one selected in the “Default Palette” drop-down menu in this same dialog window.
3. This color is displayed on the Stage whenever no Sprite covers an area of it. The same color is also used to mask the desktop if the Stage size doesn't fill the entire monitor.

Changing the Stage size:
1. Choose Modify → Movie → Properties – the Properties window appears.
2. Choose one of the standard Stage Sizes provided, or enter a custom size (in pixels). Note that most Director movies are created for 640x480 or 800x600 pixel Stage sizes. Shockwave movies are usually considerably smaller in pixel size, and often use custom height-to-width ratios.

Registration and Alignment of Cast members:
When editing a bitmap graphic (not a Quickdraw or vector shape) in the Paint window, you can select the registration point “crosshairs” tool from the palette. When selected, the window shows the registration point of the graphic. This point is where Director considers a Sprite created from this member to be located.

If you move a member’s registration point, it will shift position on the Stage without your moving the Sprite.

If you edit a bitmap member by copying a portion of it, then pasting that portion into a new member, the new member will have its reg. point in its center. This is sometimes desirable, but usually, you want to maintain the relative locations of the two graphics. In that case, you must duplicate the entire original Cast member, then cut away the unwanted portions to leave the part you want. This will preserve the location of the reg. point.

Simple Lingo Navigation:
To jump from one Frame to another in the Score, you use the “go frame” command in Lingo. This command will accept a Frame number (from the Score), or the name of a marker that you create by clicking in the marker channel at the very top of the Score. Examples:

```
go frame 15
```
```
go frame "sequence"
```

or, in simpler form:

```
go 15
```
```
go "sequence"
```

These commands must be placed in a Script – usually a Frame Script for this kind of navigation. Double-click on the Script channel of the Score. A window will open with the skeleton for an “on exitframe” handler:

```
on exitFrame
  end
```

In the blank line between the auto-generated text, type the “go” command:

```
on exitFrame
  go 25
  end
```

This can be used to create a looping section in the Score, or to jump to another area of the Score.